Micad Audit – Quarantined System Emails
Incident Report for Micad
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 09:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 30, 2023 - 11:58 UTC
Monitoring
UPDATE - We now have emails being properly delivered to our users following actions taken by Microsoft to remediate the issue they had.

We are now closely monitoring this with our clients to ensure that there is no further disruption.

We are now awaiting a root cause analysis but in the meantime, we have been developing and testing additional measures that will assist us to mitigate sooner such an issue if it arises again.

We thank you for your patience and for the excellent diagnostic feedback you gave us.

Once again, we apologise for the inconvenience that this situation may have caused.
Posted Jan 25, 2023 - 16:28 UTC
Investigating
We are aware of an issue that is potentially affecting clients with Microsoft email whereby our Micad Audit system-generated emails (e.g. password resets, report links, user registrations) are being quarantined by the receiving mail service and therefore not making it to the inbox of the end user.

We are in communication with Microsoft currently to resolve this issue as well as investigating other possible short-term mitigations that we can offer.

Please be assured that this is a matter of email receipt only and is not affecting the performance of audits or the storage/retrieval of data in any way; your audits will be available via the website at all times – it is only the email with the specific link that you may not be receiving.
When we have a full solution or mitigation, we will update here.

In the meantime, please accept our apologies for the inconvenience you may be experiencing.
Posted Jan 19, 2023 - 18:17 UTC
This incident affected: Audit (Audit) and Central Services (Email Delivery).